Rootop 服务器运维与web架构

You must install a plugin that supports the language ‘Python’

alading@venus-pc MINGW64 ~/Desktop/mail
$ /d/搜狗高速下载/sonar-scanner-3.0.3.778-windows/bin/sonar-scanner.bat
·
·
·
Caused by: You must install a plugin that supports the language ‘Python’
16:23:55.232 DEBUG: Execution getVersion
16:23:55.232 DEBUG: Execution stop

提示错误 You must install a plugin that supports the language ‘Python’,开始以为大小写问题,改成python也不行。
后来在sonarQube后台看到,配置 – 点 python ,有句话:Comma-separated list of suffixes of Python files to analyze.
意思是对指定后缀名的文件进行分析

然后在 sonar-project.properties 中修改:
sonar.language=py
再执行分析就好了。

原创文章,转载请注明。本文链接地址: https://www.rootop.org/pages/4015.html

作者:Venus

专注于 服务器运维与web架构 E-mail:venus#rootop.org

评论已关闭。